Compatibility with modern frameworks

Sqreen has been tested with modern SPA frameworks like React, Vue and Angular and static website generators like Jekyll.

Some modern web frameworks like Rails, Django or Symfony often come bundled with some of the security browser directives set by default. If you decide to rely on Sqreen to configure them, don't worry. We'll provide you with the configurations to apply at your hosting solution or on your web servers (Nginx, Apache, etc). The Sqreen configuration will override headers set within the application's code guaranteeing you there's no conflict.

If your SPA backend is compatible with Sqreen, you can also install one of our library directly there and have the configuration applied automatically in 1 click.

Get started by visiting your dashboard and create a new Single Page App in your account.