Java agent compatibility


Operating systems

Sqreen Java agent is supported on all operating systems, including Linux, Mac OS X and Windows.

Java versions

Sqreen Java agent is compatible with all Java versions starting from 1.6.

HTTP frameworks compatibility

Sqreen agent is compatible with most Servlet-based frameworks.

Other framework?

We are working on supporting more frameworks. Please, contact us if you are using a different framework. We will adjust our roadmap!

Application servers compatibility

Sqreen is tested on the following application servers:

Database compatibility (NoSQL/SQL injection protection)

Sqreen protects against SQL and NoSQL injections for the most common production databases:

  • MySQL
  • MariaDB
  • PostgreSQL
  • SQLite
  • Oracle
  • MongoDB

Other database?

Please, contact us if you are using a different database. We will adjust our roadmap!